summary refs log tree commit diff
path: root/ripple/website/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ripple/website/default.nix')
-rw-r--r--ripple/website/default.nix19
1 files changed, 5 insertions, 14 deletions
diff --git a/ripple/website/default.nix b/ripple/website/default.nix
index f72e5af..3dad32c 100644
--- a/ripple/website/default.nix
+++ b/ripple/website/default.nix
@@ -1,16 +1,7 @@
-let pkgs = import <nixpkgs> {};
-in pkgs.runCommand "ripple.unfathomable.blue" {
-  nativeBuildInputs = [ pkgs.lowdown ];
-} ''
-  mkdir $out
-  for x in ${./pages}/*.md; do
-    {
-      cat <<EOS
+{ writeTextDir }:
+
+writeTextDir "index.html" ''
   <!DOCTYPE html>
-  <title>$(lowdown -X title $x)</title>
-  <style>body { max-width: 72ch; margin: auto; }</style>
-  EOS
-      lowdown --html-no-head-ids $x
-    } >$out/$(basename $x .md).html
-  done
+  <title>Ripple</title>
+  WIP
 ''