summary refs log tree commit diff
path: root/third_party/cachunker/Cargo.toml
diff options
context:
space:
mode:
authoredef <edef@unfathomable.blue>2022-05-04 21:52:29 +0000
committeredef <edef@unfathomable.blue>2022-06-12 11:35:34 +0000
commitcb5bd26569ba33ea0cf1b696a9f0da42687a9185 (patch)
tree063f0b8411b71b5ae23725924e61ffb750ca23f3 /third_party/cachunker/Cargo.toml
parentdbaf4a91d26e684b826dd52bc39f92694629bf6a (diff)
downloadunf-legacy-cb5bd26569ba33ea0cf1b696a9f0da42687a9185.tar.zst
third_party/cachunker: init
This is the BuzHash content-defined chunker extracted from Lennart
Poettering's casync, almost verbatim, along with Rust bindings so
we can actually use it safely.

The bindings are a little bit constrained, since they don't support
streaming use, unlike the code they are wrapping. This suffices for
our use case: performance and correctness comparison to our native
Rust implementation, which should behave identically and perform
better.

Change-Id: Iee4296f661b036620bafef5a6c6671fe1a750bb6
Diffstat (limited to 'third_party/cachunker/Cargo.toml')
-rw-r--r--third_party/cachunker/Cargo.toml10
1 files changed, 10 insertions, 0 deletions
diff --git a/third_party/cachunker/Cargo.toml b/third_party/cachunker/Cargo.toml
new file mode 100644
index 0000000..7b9444f
--- /dev/null
+++ b/third_party/cachunker/Cargo.toml
@@ -0,0 +1,10 @@
+# SPDX-FileCopyrightText: edef <edef@unfathomable.blue>
+# SPDX-License-Identifier: LGPL-2.1-or-later
+
+[package]
+name = "cachunker"
+version = "0.1.0"
+edition = "2021"
+
+[build-dependencies]
+cc = "1.0.73"