summary refs log tree commit diff
path: root/ripple/website/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ripple/website/default.nix')
-rw-r--r--ripple/website/default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/ripple/website/default.nix b/ripple/website/default.nix
new file mode 100644
index 0000000..f72e5af
--- /dev/null
+++ b/ripple/website/default.nix
@@ -0,0 +1,16 @@
+let pkgs = import <nixpkgs> {};
+in pkgs.runCommand "ripple.unfathomable.blue" {
+  nativeBuildInputs = [ pkgs.lowdown ];
+} ''
+  mkdir $out
+  for x in ${./pages}/*.md; do
+    {
+      cat <<EOS
+  <!DOCTYPE html>
+  <title>$(lowdown -X title $x)</title>
+  <style>body { max-width: 72ch; margin: auto; }</style>
+  EOS
+      lowdown --html-no-head-ids $x
+    } >$out/$(basename $x .md).html
+  done
+''