summary refs log tree commit diff
path: root/ripple/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ripple/shell.nix')
-rw-r--r--ripple/shell.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/ripple/shell.nix b/ripple/shell.nix
index 9282613..03804c7 100644
--- a/ripple/shell.nix
+++ b/ripple/shell.nix
@@ -1,4 +1,5 @@
 # SPDX-FileCopyrightText: V <v@unfathomable.blue>
+# SPDX-FileCopyrightText: edef <edef@unfathomable.blue>
 # SPDX-License-Identifier: OSL-3.0
 
 with import ./nix;
@@ -12,5 +13,11 @@ mkShell {
     # needed by rust-analyzer
     rustc  # core crate code
     rustfmt  # format-on-save
+
+    # needed by prost-build
+    protobuf
   ];
+
+  # needed by prost-build
+  PROTOC = "protoc";
 }